Railway - Deploys are failing to complete – Incident details

EU West (europe-west4 / Amsterdam, Netherlands) experiencing degraded performance

Deploys are failing to complete

Resolved
Partial outage
Started 10 days agoLasted 14 minutes

Affected

Builds

Operational from 8:26 PM to 8:34 PM, Partial outage from 8:34 PM to 8:40 PM

Image Registry

Operational from 8:26 PM to 8:34 PM, Partial outage from 8:34 PM to 8:40 PM

Deployments

Updates
  • Resolved
    Resolved

    This incident has been resolved. We isolated the issue down to a Nixpacks version upgrade that caused a regression in image handling on our builders. We have reverted the Nixpacks version upgrade and are seeing nominal number of successful deploys.

  • Identified
    Identified

    A subset of deploys going through our image registry is failing. We've identified the issue and are rolling out a fix.

  • Investigating
    Investigating
    Deploys are failing to complete