Railway - Elevated error rates on EU West Edge V2 Proxy – Incident details

Elevated error rates on EU West Edge V2 Proxy

Resolved
Degraded performance
Started 3 months agoLasted 15 minutes

Affected

Edge Network

Degraded performance from 3:01 PM to 3:13 PM, Operational from 3:13 PM to 3:16 PM

EU West (europe-west4 / Amsterdam, Netherlands)

Degraded performance from 3:01 PM to 3:13 PM, Operational from 3:13 PM to 3:16 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Some traffic from a single host in Europe West to our Edge V2/TCP proxies may have been dropped between 14:29 ~ 15:09 UTC. Public traffic for users connecting to Railway-hosted workloads is not impacted.

  • Monitoring
    Monitoring

    We have rolled out a fix.

  • Identified
    Identified

    We have identified the root cause and are working on a fix. Our DDoS protection was triggered on a edge proxy host in EU West resulting in a partial blockage of internal traffic.

  • Investigating
    Investigating

    We are experiencing elevated error rates on our EU West Edge V2 Proxy for traffic originating from Europe. Users in Europe may have difficulties connecting to Railway-hosted workloads during this period.