Railway - Intermittent Build "StartToClose" Errors – Incident details

Intermittent Build "StartToClose" Errors

Resolved
Degraded performance
Started 3 months agoLasted about 8 hours

Affected

Builds

Operational from 6:29 PM to 2:30 AM

Builders

Operational from 6:29 PM to 2:30 AM

Image Registry

Operational from 6:29 PM to 2:30 AM

Third-Party: npm Registry

Third-Party: Github Integrations

Third Party: Docker Hub

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Update

    We are continuing to work on a fix for this incident. We are currently testing a fix internally before rolling out to users.

  • Identified
    Identified

    Users have reported that their builds will fail with a 'startToClose' error. We have found the cause of these arrors and are implementing a fix. Telemetry shows that 99 percent of builds are still going out. We intend to share a post-mortem on this phenomena.