Railway - service domain and custom domain creation may be delayed – Incident details

service domain and custom domain creation may be delayed

Resolved
Degraded performance
Started 1 day agoLasted about 1 hour

Affected

Dashboard

Degraded performance from 4:40 PM to 5:46 PM

Updates
  • Resolved
    Resolved

    We identified a caching issue on the dashboard where high latency on domain creation caused the cached domains list to become stale. The new domains were created and successfully propagated to proxies, but failed to appear in the UI. We've rectified the caching issue and reduced the upstream timeouts to the external vendors API. This is incident is now resolved.

  • Identified
    Identified

    Due to an ongoing incident with an upstream provider since approximately 1pm UTC, custom and service domain creation can take upto 15s. During this time, the dashboard state of domains may go out of sync. We're lowering the timeout to our upstream provider to remediate this.